mirror of
https://github.com/daylinmorgan/oizys.git
synced 2024-11-05 06:03:15 -06:00
20 lines
322 B
Nix
20 lines
322 B
Nix
{
|
|
inputs,
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}: let
|
|
inherit (lib) mkIfIn;
|
|
cfg = config.oizys.languages;
|
|
zig = inputs.zig2nix.outputs.packages.${pkgs.system}.zig.master.bin;
|
|
in {
|
|
config = mkIfIn "misc" cfg {
|
|
environment.systemPackages = with pkgs;
|
|
[
|
|
go
|
|
rustup
|
|
]
|
|
++ [zig];
|
|
};
|
|
}
|