mirror of
https://github.com/daylinmorgan/oizys.git
synced 2024-11-05 06:03:15 -06:00
21 lines
513 B
Nix
21 lines
513 B
Nix
{
|
|
fetchFromGitHub,
|
|
buildNimPackage,
|
|
}:
|
|
buildNimPackage (finalAttrs: {
|
|
pname = "nph";
|
|
version = "0.6.0";
|
|
src = fetchFromGitHub {
|
|
owner = "arnetheduck";
|
|
repo = "nph";
|
|
rev = "v${finalAttrs.version}";
|
|
hash = "sha256-9t5VeGsxyytGdu7+Uv/J+x6bmeB5+eQapbyp30iPxqs=";
|
|
};
|
|
# replace gorge(git...) call to for version
|
|
patchPhase = ''
|
|
runHook prePatch
|
|
sed -i 's/Version = gorge(.*/Version = """v${finalAttrs.version}\n"""/' src/nph.nim
|
|
runHook postPatch
|
|
'';
|
|
doCheck = false;
|
|
})
|