oizys/lib/templates/dev/flake.nix
2024-11-27 11:26:49 -06:00

27 lines
580 B
Nix

{
description = "";
inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
outputs =
{ nixpkgs, ... }:
let
inherit (nixpkgs.lib) genAttrs;
systems = [
"x86_64-linux"
"x86_64-darwin"
"aarch64-linux"
"aarch64-darwin"
];
forAllSystems = f: genAttrs systems (system: f (import nixpkgs { inherit system; }));
in
{
devShells = forAllSystems (pkgs: {
default = pkgs.mkShell {
packages = with pkgs; [
# insert packages here
];
};
});
};
}