mirror of
https://github.com/daylinmorgan/oizys.git
synced 2024-11-05 06:03:15 -06:00
19 lines
379 B
Nix
19 lines
379 B
Nix
{ self, enabled, ... }:
|
|
{
|
|
imports = with self.nixosModules; [ nix-ld ];
|
|
|
|
oizys = {
|
|
desktop = enabled;
|
|
nix-ld = enabled;
|
|
rune.motd = enabled;
|
|
};
|
|
|
|
# Enable the X11 windowing system.
|
|
services.xserver = {
|
|
enable = true;
|
|
displayManager.startx.enable = true;
|
|
windowManager.qtile.enable = true;
|
|
};
|
|
|
|
users.users.daylin.extraGroups = [ "docker" ];
|
|
}
|